Error en la firma del repositorio de Google para Linux: Solución

Cada cierto tiempo la gran G, aka Google, suele cambiar la firma del repositorio para Linux, en donde aloja los paquetes .deb y .rpm de su navegador Chrome.

El tema es que si ya tenías el repositorio agregado cuando haces alguna actualización o refresco de repositorios, ya sea desde alguna GUI o la terminal, te va a salir un error porque no reconoce la firma y entiende que el repositorio no es seguro al no estar firmado.

Algo como esto que me ha salido en mi Linux Mint tras instalar hoy el Google Chrome desde el .deb.

  • W: Error de GPG: http://dl.google.com/linux/chrome/deb stable Release: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 6494C6D6997C215E
  • E: El repositorio «http://dl.google.com/linux/chrome/deb stable Release» no está firmado.
  • N: No se puede actualizar de un repositorio como este de forma segura y por tanto está deshabilitado por omisión.
  • N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.

Lo ideal sería que fuera la propia Google quien cambiara la firma de su repositorio de manera automática, pero como no lo hace, el canalla, lo haremos nosotros de manera manual.

Desde una terminal bajaremos y agregaremos la nueva firma desde los propios repositorios de Google.

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -
sudo apt update

Y asunto arreglado, nueva firma y ningún mensaje de error 😉

Otra opción sería usar el navegador Chromium, que es como el Chrome pero sin las mierdas espiatorias de este. Normalmente Chromium se encuentra en los repositorios de toda distro Linux decente que se precie.

Continuamos en línea…

Vía | Linux Mint Forums

9 comentarios sobre “Error en la firma del repositorio de Google para Linux: Solución

Agrega el tuyo

  1. El único inconveniente que tengo en chromium es que no puedo usar spotify, ya que cuando lo hago es desde el navegador. No tiene instalado el widevine -creo que es- y no he podido dar en la tecla para solucionarlo. En firefox va como trompada.

    Me gusta

  2. Por cierto, en Chromium ni Spotify ni Netflix, en Firefox, a partir de la 54 cagaron el inspector de elementos y andá como el culo (herramienta que, como desarrollador me es imprescindible). Solución: instalé Vivaldi, está hecho con el código fuente de Chromium, por lo que usa el mismo motor de renderizado y toma sus extensiones de la tienda de Chrome, pero consume la mitad de RAM que éste.

    Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Blog de WordPress.com.

Subir ↑

A %d blogueros les gusta esto: