De vuelta a openSUSE con Leap 42.2, mis 3 primeros pasos que igual pueden ser los tuyos

Después de la salida oficial de openSUSE Leap 42.2 ¿como ha sonado eso de “salida” verdad? me he decidido a instalarla en el sitio de Ubuntu, /dev/sda2. Chao Ubuntu, siempre es la sacrificada a la hora de probar nueva distro. (probecillo)

No pretendo hacer un “que hacer después de instalar openSUSE Leap 42.2”, eso lo harán otros que saben más que yo de la distro del camaleón. Yo solo voy a contarte los tres pasos que he seguido después de instalar la distro y que me han resultado imprescindibles.

1: Actualizar el sistema e instalar los drivers gráficos y demás recomendados

Desde la terminal podemos actualizar el sistema con zypper como ya sabemos.

sudo zypper ref && sudo zypper up

Ahora iremos a Yast para agregar repositorios extras, en mi caso en este primer paso he agregado el de Packman, el de Nvidia y el de libdvdcss. También podemos quitar de la lista de repositorios la línea del USB de instalación, ya no nos hace falta.

Lo siguiente que he hecho ha sido instalar los drivers gráficos para mi Nvidia Geforce 210. Para este modelo de gráfica los actuales son los 340.98, versión que se encuentra en el repo Nvidia que había agregado.

La mejor forma de instalarlo es como bien indican los chicos de openSUSE, instalando los paquetes recomendados.

Además de los drivers Nvidia, en mi caso, se instalaran otros muchos paquetes necesarios que no vienen mal. Podemos hacerlo vía terminal.

sudo zypper ref
sudo zypper install-new-recommends

O podemos hacerlo de forma gráfica en el propio Yast desde: Yast – instalar / desinstalar software – Extras – Instalar todos los paquetes recomendados que coincidan

Yo lo hice así, aquí tenéis una captura del proceso desde el horrible Adwaita, antes de enchular la distro.

Después de esto debemos reiniciar la distro para que todo se asiente como es debido.

2: Enchular la distro, asuntos del Artwork

Cierto es que el Gnome que entrega openSUSE es de los mejores pero lo dan más feo que pegarle a un padre con un calcetín sudado. Por eso vamos a ver algunos buenos temas para dejar al camaleón más bonito que un San Luis.

Para este menester yo he tirado del OBS de la distro, o repos de la comunidad. Podemos encontrar software que necesitemos y que no se encuentre en repositorios desde el portal de software, tan solo tenemos que escribirlo en su buscador y si está estamos de suerte.

En todas las opciones he elegido el método 1 Click Install, vosotros elegís el repo del usuario que más os guste. Los que yo elegí se ven en la captura de mis repositorios.

Con esto yo creo que andamos bien servidos, al menos para comenzar. A mi me basta y así la tengo, a la distro me refiero.

Tema GTK Arc, tema de iconos Papirus GTK, Tema Shell Paper.

3: Algo de software necesario y que mola

En los repositorios de openSUSE hay miles de programas y si a esto unimos el repositorio de Packman estamos casi cubiertos, pero siempre hay algo que no está y que necesitamos.

Cada uno trabajamos nuestra distro de maneras distinta, yo te voy a decir algún programa destacable de los que he puesto en esta opción.

  • inxi (Leap 42.2) para que funcione a full instalar de repos Mesa-demo-x)
  • SimpleScreenRecorder (Leap 42.2) (para tener la última versión 0.3.8)

  • Ardour 5.4.x (Leap 42.2)

  • Ahora hablemos del cliente Twitter Corebird, que merece explicación aparte.

    La versión que hay en repos de openSUSE es viejuna, la 1.1, en OBS encontraremos dos versiones 1.3.3, la de Leap 42.2 (1.3.3.git) que no funciona bien, se cierra, y la de Tumbleweed, versión final estable, que funciona perfectamente. Instalaremos esta de Tumbleweed pero siguiendo unos pasos.

    Seguimos el procedimiento normal de 1 Click Install y nos agregará el repositorio (openSUSE:Factory) y nos instalará Corebird 1.3.3.

    Nada más instalar Corebird y antes de tocar cualquier otra cosa nos dirigimos a Yast, Respositorios de Software y deshabilitamos este repositorio que apunta a tumbleweed.

    Una vez marcado el repositorio destildamos las opciones Activado y Actualizar automáticamente y le damos a aceptar. También podemos eliminar el repositorio, yo lo voy a dejar simplemente deshabilitado por si en un futuro me sirve para actualizar de nuevo Corebird.

    REPITO DE NUEVO: Ni se os ocurra actualizar Leap 42.2 teniendo este repositorio Tumbleweed activo que la liáis, os váis para arriba y no queremos eso, solo hemos tomado Corebird 1.3.3.

    La única pega que tiene Corebird en openSUSE es que no reproduce vídeo desde el TL, no he encontrado solución, por lo demás funciona perfectamente. Esto sale al picar en elgún vídeo del TL.

    Y por último un extra, si instaláis Shutter y queréis tener activa la opción Editar necesitáis instalar la siguiente biblioteca, que no se por qué no viene en repos.

    Y nada más, esto ha sido una pequeña muestra de mis primeros pasos en openSUSE Leap 42.2 y alguna cosita que he instalado, por supuesto hay mucho más que hacer, instalar software multimedia, de internet, etcétera, pero eso ya sabemos hacerlo nosotros solitos tirando de repositorios.

    Para terminar os dejo nuevo captura, en realidad todas mis distros Gnomeras tienen el mismo aspecto. Leap 42.2 va excelente, muy sólida, la pena es que no le metieran Gnome 3.22, pero con Gnome 3.20 también se come.

    Continuamos en línea…

    28 comentarios sobre “De vuelta a openSUSE con Leap 42.2, mis 3 primeros pasos que igual pueden ser los tuyos

    Agrega el tuyo

    1. Opensuse, aquella buena distro la cual debería de ser un poquito mas sencilla. Sin duda no es para todo el mundo y puede echar para atrás a los mas nuevos. Aun sin ser perfecta todos deberían de fijarse en Mint, es un claro ejemplo de la distro la cual apetece quedarse si vienes de otros SO.

      Me gusta

      1. Mcder, creo que estás equivocado.
        Estoy es lo que yo se sobre zypper dup, tengo muchos repositorios y sin problemas.

        Usar correctamente los repositorios en openSUSE. Prioridades.
        Use correctly repositories on openSUSE. Priorities.

        Cuanto más bajo es el número de la prioridad mayor es la prioridad del repositorio, siendo 0 la más alta y 200 la más baja.
        zypper up –> actualiza los paquetes manteniendo el repositorio en el que están instalados.
        zypper dup –> Instala los paquetes según la prioridad que le hayas dado a los repositorios. Es decir, si tenías un paquete instalado en un repositorio con prioridad 99, aunque éste sea la versión más reciente, lo cambiará al repositorio que tenga más prioridad, es decir si está en un repositorio con prioridad 95 instalará el paquete que esté en ese repositorio.

        https://plus.google.com/u/0/collection/EEkbME

        Me gusta

      2. Bajo mi punto de vista @yoyo NO debes usar “zypper dup” a la ligera..
        No hagas zypper dup.

        Fijaos en este comando:
        zypper dup –from Packman_Repository

        Está diciendo que se instalen todos los paquetes que actualmente tengo instalados desde este repositorio independientemente de la versión.
        Ahora bien, si quiero que cada paquete que instale se instale desde el repositorio Packmam tendré que darla prioridad a ese repositorio.

        Cuando un paquete se instala, se mantiene el repositorio del que se haya instalado a no ser que especifiquemos que se instale de otro repositorio. Es decir, podemos tener instalada una versión más vieja que la que tengamos disponible en otro repositorio, porque, es el primer paquete que instalamos.
        Por eso nos sale en la terminal cuando hacemos un “zypper up”
        “Las siguientes 472 actualizaciones NO serán instaladas” (en mi caso), incluso haciendo un “zypper dup” como tengo bien gestionadas la prioridades apenas 5 paquetes se me cambian de repositorio, que repito otra vez, no aconsejo hacer “zypper dup” a no ser que sea para actualizar todo el sistema desde un versión más antigua, en cuyo caso debemos de desactivar todos los repositorios anteriores y dejar sólo activados los repositorios de la nueva versión.

        Me gusta

    2. Madre mía Yoyo, te ha quedado Gnome rico rico como el rabo de tocino, que solemos decir por maño landia.
      Yo en cuanto acabe un proyecto cambio a OpenSuse e intentaré ponerle el tema de Apricity, que me encantó.

      Un saludo!

      Me gusta

    3. Hola amigo,

      Creo que en el caso de corebird es mejor descargar el src.rpm de corebird y recompialr el paquete usando librerias disponibles en openSUSE Leap 42.2. Al usar el repo Tumbleweed, en la instalación se usarán librerías de este por lo que contaminas tu sistema… Recompilar el paquete es más fácil y limpio…

      Pasos:

      zypper in rpm-build
      wget http://download.opensuse.org/tumbleweed/repo/src-oss/suse/src/corebird-1.3.3-1.1.src.rpm

      rpmbuild –rebuild corebird-1.3.3-1.1.src.rpm

      Si el paquete necesita instalar algunas dependencias para poder compilar, se listará el nombre de los paquetes (dependencia) a instalar y una vez instaladas las dependencias vuelves a ejecutar el comando anterior.

      En el directorio /home o /root se creará una carpeta llamada rpmbuild y dentro habrá una carpeta llamada RPMS la cual contiene los paquetes rpm listos para instalar en tu openSUSE Leap 42.2.

      Saludos

      Me gusta

      1. @peterchero Gracias por el dato.

        Creo recordar que solo se instaló el Corebird 1.3.3 pero no arrastró a ninguna bliblioteca consigo porque antes ya había instalado el Corebird de otro repo para Leap 42.2, pero lo que tu cuentas es ideal.

        Un saludo

        Me gusta

    4. Hola a todos, instale esos paquetes y después me dio por ir y siguiendo el interface gráfico actualice 2000 ypico actualizaciones automáticas que encontró gnome, ahora tengo un problema al que no encuentro solución en los foros, pero estoy muy limitado de conocmientos en adminisrtacion de Linux y mas en escritorios.
      El problema es que no me salen las ventanas, es decir pincho en firefox y aparece porque se esta cargando y dibuja la ventana y luego desaparece, no me deja ni la de settings o características de la barra superior, alguna aplicación si carga la ventana pero otras no, sin embargo la de terminal si.
      Si volver a reinstalar el opensuse hay alguna solución o mejor hago una instalación limpia otra vez?, lo voy a usar de servidor, probablemente para el correo y alguna cosa más.

      Me gusta

    5. Muy bueno!!
      Sobre corebird, mejor no mezclar repositorios!!

      En el repo Gnome:apps está una versión más actual:
      http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_Leap_42.2/x86_64/

      Añade ese repo para Leap 42.2 y actualiza desde él…

      La versión 1.3.3 veo que está en proceso de ser actualizada:
      https://build.opensuse.org/package/show/GNOME:Apps/corebird

      Pero ha fallado la compilación y empaquetado para Leap 42.2. Si alguien se anima a solucionarlo pues adelante!! 😉

      Saludos.

      Me gusta

      1. Hola, victorhck

        Por lo que veo en ese repo de Gnome está Gnome 3.22 y Leap viene con 3.20. Si lo agregamos y actualizamos desde el estaríamos actualizando a Gnome 3.22 ¿es así, no?

        No se si eso es lo que quieren los de Leap aunque yo encantado con Gnome 3.22

        Gracias por la info.

        Me gusta

      1. Instalarla en otra partición aparte pero openSUSE te instalaría su GRUB y agregaría a Manjaro por lo que si quieres luego tener el GRUB de Manjaro puedes recuperarlo.

        Estando en Manjaro y dede la terminal:

        sudo grub-install /dev/sda
        sudo update-grub
        

        O también para regenerar GRUB

        sudo grub-mkconfig -o /boot/grub/grub.cfg
        

        Me gusta

    6. al final lo que hice fue instalar limpio otra vez y poner de escritorio a KDE, la verdad que me gusta más que los nuevos gnome”s3″, el único gnome que me gusta es el de Debian de toda la vida. Leí que el KDE 5 ya no era nada pesado y la verdad que lo noto “casi” incluso mejor que el Gnome y con los servicios que quiero instalar así no pierdo el tiempo con pruebas de instalación de escritorio, pero en cuanto tenga tiempo lo pruebo en una máquina virtual que esta es una física.

      Me gusta

    Responder

    Introduce tus datos o haz clic en un icono para iniciar sesión:

    Logo de WordPress.com

    Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

    Imagen de Twitter

    Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

    Foto de Facebook

    Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

    Google+ photo

    Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

    Conectando a %s

    Blog de WordPress.com.

    Subir ↑

    A %d blogueros les gusta esto: