Corebird 1.3.3 ha llegado corrigiendo numerosos errores

Si hablamos de clientes Twitter para Linux solo hay una palabra, Corebird. Ninguno de los otros tiene un desarrollo tan rápido, un tan buen desempeño y no son compatibles con las nuevas funciones de Twitter. En cuanto a diseño solo Birdie le hacía sombra pero desde que este se hizo exclusivo para Elementary OS perdió el interés de la mayoría de la comunidad que no usa esa distro.

A estas alturas de la vida no voy a explicar lo que es Corebird pues de sobra ha salido en este blog, sale prácticamente todas las semanas. A nosotros lo que realmente nos importa es su nueva versión 1.3.3 la cual corrige numerosos fallos que tenía la anterior, ahora es más completo y estable.

Esta es la lista de cambios, o changelog que dicen los angloparlantes. Perdonen que no la traduzca pero ando flojo, será cosa de ser andaluz, tirar de tópicos de esta tierra me excusa.

  • Support longer tweets in a few more places
  • Properly escape ampersand characters in user mentions to fix
    GtkLabel warnings about wrong escape characters in tooltips
  • Fix tweet length calculations for whitespace-only tweets
  • Check for duplicated entries in media arrays. This is apparently a
    problem on Twitter’s side but led to crashes in Corebird (see #627)
  • Use the correct nsfw status of a tweet, i.e. the one that can
    actually show images.
  • Fix a crash when sending a tweet with multiple images attached
  • Fix tweet length calculation of quote tweets. This previously led to
    tweets getting rejected by the server even though Corebird claimed
    they were fine. See #628

Ubuntu 16.04, 16.10 y basadas como Linux Mint

Como siempre tiraremos del repo PPA de Panda Jim. Si ya lo tenías basta con actualizar y si no lo tenías le damos pal pelo desde la terminal.

sudo add-apt-repository ppa:ubuntuhandbook1/corebird -y
sudo apt update
sudo apt install corebird

En Debian testing podemos probar a bajarnos el .deb de Ubuntu que creo recordar funciona.

Arch Linux y basadas como Manjaro o Antergos

Normalmente está en AUR.

yaourt -S corebird --noconfirm

Pero se puede dar el caso de que, como en Antergos y Manjaro, ya tengan a Corebird en sus repos oficiales y AUR no nos haga caso.

En ese caso lo que yo hago es, bajarme de AUR el paquete de Corebird, (Download snapshot, a la derecha) descomprimo el paquete el cual suelta una carpeta con un PKGBUILD dentro. Con la terminal dentro de esa carpeta en donde está el PKGBUILD le tiramos un makepkg -si y tiramos millas. Usar este método solo si aún no lo actualizaron en repos oficiales.

KaOS

La distro de Anke está de enhorabuena pues fue la primera en tener la nueva versión gracias a la comunidad y su repo comunitario KCP.

Tiraremos de la utilidad kcp para instalarlo en caso de que no lo tengáis aún. Antes instalaremos un par de dependencias.

kcp -di rest
kcp -di libgstgtkskin
kcp -i corebird

Para las demás distros del universo linuxero no estoy muy puesto, supongo que lo irán agregando a sus repos oficiales o comunitarios.

De momento os lo presento en mi Antergos, en cuanto inicie en Linux Mint le tiraré un update.

Corebird sigue avanzando y se convierte en el mejor cliente Twitter para Linux que haya existido. Esta actualización resuelve el problema de los cierres aleatorios, entre otras cosas, y además es compatible con los nuevos tuits largos.

Gracias al amigo Miguel, @miguellogo7 en Twitter, que me dio el chivatazo de esta nueva versión, loopset en Github, que además es el que lo mantiene en el KCP de KaOS.

Continuamos en línea…

11 comentarios sobre “Corebird 1.3.3 ha llegado corrigiendo numerosos errores

Agrega el tuyo

    1. Debian no es compatible con los PPA de Ubuntu, eso es solo para Ubuntu y basadas como Linux Mint.

      Por otro lado, esta versión de Corebird tampoco es compatible con Debian 8.6 estable, si valdría para Debian testing Stretch, pero bajando el paquete .deb de manera individual no mediante PPA.

      Un saludo

      Le gusta a 1 persona

  1. Lo estoy probando ya unos días y me está resultado agradable y práctico el uso de esta aplicación pero me falla algo que consulto mucho y son los TT, soy yo o aún no está implementado?.

    Un Saludo

    Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Blog de WordPress.com.

Subir ↑

A %d blogueros les gusta esto: